mango_comms 1.0.2

  • Readme
  • Changelog
  • Installing
  • 67

comms #

Mango API: Comms Email, SMS and other Messages are all to handled by Comms.

Run with Docker #

  • $ docker build -t avosa/comms:dev .
  • $ docker rm CommsDEV
  • $ docker run -d -p 8085:8085 -e SMTPUsername=frik@avosa.co.za -e SMTPPassword=not_real -e SMTPAddress=smtp.gmail.com -e SMTPPort=587 --network mango_net --name CommsDEV avosa/comms:dev
  • $ docker logs CommsDEV

Mango-Comms #

1.0.2 #

  • Fixed Resource path

1.0.1 #

  • Removed "To" parameter from Message create

1.0.0 #

  • Initial Release
  • Added objects from mango-ui

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  mango_comms: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:mango_comms/bodies/message.dart';
import 'package:mango_comms/commsapi.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
46
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15

Analysis suggestions

Package not compatible with runtime flutter-native on Android

Because:

  • package:mango_comms/commsapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on Linux

Because:

  • package:mango_comms/commsapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on Windows

Because:

  • package:mango_comms/commsapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on iOS

Because:

  • package:mango_comms/commsapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime flutter-native on macOS

Because:

  • package:mango_comms/commsapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime native

Because:

  • package:mango_comms/commsapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Package not compatible with runtime native-aot

Because:

  • package:mango_comms/commsapi.dart that imports:
  • package:mango_ui/requester.dart that imports:
  • dart:html

Health issues and suggestions

Document public APIs. (-1 points)

10 out of 10 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and mango_comms.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 < 3.0.0
mango_ui ^1.0.3 1.0.3