malison 0.11.3

Dart native js
Flutter Android iOS web

A little terminal UI package for the browser.

1
likes
80 / 110
pub points
53 %
popularity

We analyzed this package on Sep 22, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 48 out of 462 API elements (10.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: The value of the field '_canvas' isn't used.

lib/src/retro_terminal.dart:18:28

   ╷
18 │   final html.CanvasElement _canvas;
   │                            ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/retro_terminal.dart

INFO: DO use curly braces for all flow control structures.

lib/src/user_interface.dart:81:36

   ╷
81 │       for (var screen in _screens) screen.resize(terminal.size);
   │                                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/user_interface.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
piecemeal>=0.3.7 <0.5.00.4.20.4.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
80
pub points
53%
popularity

A little terminal UI package for the browser.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

rnystrom@google.com

License

MIT (LICENSE)

Dependencies

piecemeal

More

Packages that depend on malison