magpie_log 1.0.0

magpie_log #

add log to flutter project with UI

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:flutter_redux/flutter_redux.dart';
import 'package:magpie_log/interceptor/intercepter_screen_log.dart';
import 'package:magpie_log/interceptor/interceptor_circle_log.dart';
import 'package:redux/redux.dart';

import 'states/app_state.dart';
import 'top_screen.dart';
import 'under_screen.dart';

void main() {
  final store = Store<AppState>(reducer,
      middleware: [CircleMiddleWare()], initialState: AppState.initState());
  runApp(MyApp(store));
}

class MyApp extends StatelessWidget {
  final Store<AppState> store;

  MyApp(this.store);

  @override
  Widget build(BuildContext context) {
    return StoreProvider<AppState>(
      store: store,
      child: MaterialApp(
        routes: {
          '/': (BuildContext context) => TopScreen(),
          '/UnderScreen': (BuildContext context) => UnderScreen(),
        },
        navigatorObservers: [
          LogObserver<AppState>(),
        ],
        title: 'Flutter Demo',
        theme: ThemeData(primarySwatch: Colors.deepOrange),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  magpie_log: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:magpie_log/magpie_log.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
35
Learn more about scoring.

We analyzed this package on Jun 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package does not support Flutter platform android

Because of import path [package:magpie_log/magpie_log.dart, package:magpie_log/file/data_analysis.dart, package:magpie_log/file/file_utils.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart]

Package does not support Flutter platform ios

Because of import path [package:magpie_log/magpie_log.dart, package:magpie_log/file/data_analysis.dart, package:magpie_log/file/file_utils.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart]

Package does not support Flutter platform linux

Because of import path [package:magpie_log/magpie_log.dart, package:magpie_log/file/data_analysis.dart, package:device_info/device_info.dart]

Package does not support Flutter platform macos

Because of import path [package:magpie_log/magpie_log.dart, package:magpie_log/file/data_analysis.dart, package:magpie_log/file/file_utils.dart, package:path_provider/path_provider.dart, package:path_provider_linux/path_provider_linux.dart]

Package does not support Flutter platform web

Because of import path [package:magpie_log/magpie_log.dart, package:magpie_log/file/data_analysis.dart, package:magpie_log/file/file_utils.dart, package:path_provider/path_provider.dart]

Package does not support Flutter platform windows

Because of import path [package:magpie_log/magpie_log.dart, package:magpie_log/file/data_analysis.dart, package:magpie_log/file/file_utils.dart, package:path_provider/path_provider.dart]

Package not compatible with SDK dart

because of import path [magpie_log]

Health suggestions

Fix lib/handler/statistics_handler.dart. (-1.99 points)

Analysis of lib/handler/statistics_handler.dart reported 4 hints:

line 4 col 8: Unused import: 'package:flutter/material.dart'.

line 11 col 16: The value of the field '_tag' isn't used.

line 37 col 3: Prefer using /// for doc comments.

line 99 col 61: Name non-constant identifiers using lowerCamelCase.

Fix lib/file/data_analysis.dart. (-0.50 points)

Analysis of lib/file/data_analysis.dart reported 1 hint:

line 187 col 66: The value of the local variable 'product' isn't used.

Fix lib/file/data_statistics.dart. (-0.50 points)

Analysis of lib/file/data_statistics.dart reported 1 hint:

line 3 col 8: Unused import: 'package:flutter/material.dart'.

Fix lib/ui/log_screen.dart. (-0.50 points)

Analysis of lib/ui/log_screen.dart reported 1 hint:

line 2 col 8: Unused import: 'dart:math'.

Format lib/interceptor/intercepter_screen_log.dart.

Run flutter format to format lib/interceptor/intercepter_screen_log.dart.

Maintenance issues and suggestions

Support latest dependencies. (-30 points)

The version constraint in pubspec.yaml does not support the latest published versions for 3 dependencies (flutter_redux, fluttertoast, redux).

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
cupertino_icons ^0.1.2 0.1.3
device_info ^0.4.1+3 0.4.2+4
flutter 0.0.0
flutter_redux ^0.5.2 0.5.4 0.6.0
fluttertoast ^3.1.3 3.1.3 4.0.1
json_annotation ^3.0.0 3.0.1
path_provider ^1.5.0 1.6.10
redux ^3.0.0 3.0.0 4.0.0
rubber ^0.4.0 0.4.0
Transitive dependencies
after_layout 1.0.7+2
collection 1.14.12
file 5.1.0
intl 0.16.1
meta 1.1.8
path 1.7.0
path_provider_linux 0.0.1+1
path_provider_macos 0.0.4+3
path_provider_platform_interface 1.0.2
platform 2.2.1
plugin_platform_interface 1.0.2
process 3.0.13
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
xdg_directories 0.1.0
Dev dependencies
build_runner ^1.7.0
flutter_test
json_serializable ^3.2.3