magic 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 0

Magic #

Do you want to start with thinking your pages only? This magical package has a lot of features that you don't want to write again. You can start using this package by like a boilerplate and you have a lot of features.

Let's start to use by cloning the anilcancakir/magic repository.

[0.0.2] - Fixing first release issues

  • Added license.
  • Changed readme file.
  • Changed some variables in pubspec.yaml file.
  • Updated version.
  • Formatted the library dart files.

[0.0.1] - Initial

  • The package initial completed.


import 'package:app/config/app.dart';
import 'package:magic/magic.dart';

main() {
  new Magic().boot(config: appConfig, environment: {
    'app.env': 'development',
    'api.url': 'http://localhost:8000/api/'

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  magic: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:magic/magic.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0