madob_generator 0.2.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 61

MadobGenerator #

MadobGenerator provides automated code generation for managed database objects used by Madob.

Example #

@MadobType(typeId: 0)
abstract class IProject implements IKey {
  @override
  String get managedKey;

  @MadobGetter(1)
  Future<String> get title;
  @MadobSetter(1)
  Future<void> setTitle(String newTitle);
}

MadobGenerator #

0.2.0 #

  • Added code generation for object-references

0.1.0 #

  • Initial release

example/lib/main.dart

// Nothing to see here, go to src/ for an code generation example

void main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  madob_generator: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:madob_generator/madob_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
22
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Mar 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
analyzer ^0.39.4 0.39.4
build ^1.2.2 1.2.2
code_builder ^3.2.1 3.2.1
dart_style ^1.3.3 1.3.3
hive ^1.4.0+1 1.4.1+1
hive_generator ^0.7.0 0.7.0+2
madob ^0.1.0 0.1.1
meta ^1.1.8 1.1.8
source_gen ^0.9.4+7 0.9.5
Transitive dependencies
_fe_analyzer_shared 1.0.3
args 1.6.0
async 2.4.1
built_collection 4.3.2
built_value 7.0.9
characters 0.3.1 0.5.0
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.16.1
dartx 0.2.0 0.3.0
fixnum 0.10.11
glob 1.2.0
html 0.14.0+3
js 0.6.1+1
logging 0.11.4
matcher 0.12.6
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.9.3
path 1.6.4
pub_semver 1.4.4
quiver 2.0.5 2.1.3
source_span 1.7.0
stack_trace 1.9.3
string_scanner 1.0.5
term_glyph 1.1.0
time 1.2.0
typed_data 1.1.6
uuid 2.0.4
watcher 0.9.7+14
yaml 2.2.0
Dev dependencies
effective_dart ^1.2.1
pedantic ^1.8.0 1.9.0
test ^1.6.0