hive_generator 0.5.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 94

Extension for hive please go there for documentation.

0.5.2 #

  • Fix bug with Uint8Lists

0.5.1 #

  • Bump Hive version

0.5.0 #

  • Support final members

0.4.0+2 #

  • Support for Lists and Maps in strong mode

0.4.0+1 #

  • Support for enums
  • Sanity checks
  • Bugfixes

0.3.0 #

  • Support for typed lists
  • Bugfixes
  • Breaking: Not compatible to previous adapters

0.2.0 #

  • Improve performance of adapers
  • Cast lists to the correct type

0.1.0+1 #

  • First release

example/README.md

Hive samples #

Go here for samples using Hive.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hive_generator: ^0.5.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:hive_generator/hive_generator.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
88
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
94
Learn more about scoring.

We analyzed this package on Dec 12, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.1+4

Health issues and suggestions

Document public APIs. (-1 points)

2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
analyzer >=0.36.0 <0.40.0 0.39.2+1
build ^1.1.6 1.2.2
hive >=1.0.0 <2.0.0 1.1.1 1.2.0-dev
source_gen ^0.9.4+4 0.9.4+6
Transitive dependencies
_fe_analyzer_shared 1.0.1
args 1.5.2
async 2.4.0
charcode 1.1.2
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.16.1
dart_style 1.3.3
glob 1.2.0
html 0.14.0+3
js 0.6.1+1
logging 0.11.3+2
meta 1.1.8
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
path 1.6.4
pointycastle 1.0.2
pub_semver 1.4.2
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+13
yaml 2.2.0
Dev dependencies
build_runner any
build_test any
pedantic 1.7.0 1.9.0
test ^1.6.4