lumberjack 1.0.0-rc.1

Dart native js
Flutter Android iOS web

Hierarchical logging for Dart. Supports multiple transports, zones, and more.

0
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Oct 28, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 54 out of 69 API elements (78.3 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 51 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/io.dart:30:27

   ╷
30 │             dateFormat ?? new DateFormat("EEE, MMM d, yyyy @ HH:mm:ss") {
   │                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/io.dart

INFO: Unnecessary new keyword.

lib/io.dart:42:7

   ╷
42 │ ┌       new AnsiLogPrinter(stdout,
43 │ │           backgroundColors: backgroundColors,
44 │ │           foregroundColors: foregroundColors,
45 │ └           dateFormat: dateFormat)
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/io.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
intl^0.15.70.15.80.16.1
io^0.3.20.3.40.3.4
logging^0.11.00.11.40.11.4
meta^1.0.01.2.31.2.3
quiver_hashcode^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.15.7` on intl does not support the latest published version `0.16.1`

pubspec.yaml:10:9

   ╷
10 │   intl: ^0.15.7
   │         ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
90
pub points
0%
popularity

Hierarchical logging for Dart. Supports multiple transports, zones, and more.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

thosakwe@gmail.com

License

MIT (LICENSE)

Dependencies

intl, io, logging, meta, quiver_hashcode

More

Packages that depend on lumberjack