lori_sdk 0.6.9
lori_sdk: ^0.6.9 copied to clipboard

A Flutter package to access Neomode's API (LORI). The package encapsulates most of the complexity and provide an easy way to connect to the best omnichannel platform.

0
likes
60/ 130
pub points
52%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 124 out of 2303 API elements (5.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:lori_sdk/data/api/firebase/firebase_api.dart that imports:
  • package:lori_sdk/data/lori_api.dart that imports:
  • package:lori_sdk/data/lori_push_notification_token.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 39 issues. Showing the first 2:

lib/data/api/firebase/firebase_api.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/data/api/sales/commerce/sales_commerce_api.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.01.15.01.15.0
dio^3.0.83.0.104.0.0
firebase_performance^0.4.0+10.4.30.7.1+1
flutterflutter0.0.00.0.0
flutter_phoenix^0.1.00.1.01.0.0
http^0.12.0+40.12.20.13.4
intl^0.16.00.16.10.17.0
json_annotation^3.1.03.1.14.3.0
path^1.6.41.8.01.8.0
shared_preferences^0.5.60.5.12+42.0.8
simple_rsa^0.0.50.0.50.0.5
sqflite^1.2.11.3.2+42.0.0+4
uuid^2.2.22.2.23.0.5
validators^2.0.0+12.0.13.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
basic_utils-2.7.13.7.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
convert-2.1.13.0.1
crypto-2.1.53.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase_core-0.5.31.7.0
firebase_core_platform_interface-2.1.04.0.1
firebase_core_web-0.2.1+11.1.0
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
logging-0.11.41.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
path_provider_linux-0.0.1+22.1.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
pedantic-1.11.11.11.1
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
pointycastle-2.0.13.3.4
process-4.2.34.2.3
quiver-2.1.53.0.1+1
random_string-2.3.12.3.1
shared_preferences_linux-0.0.2+42.0.2
shared_preferences_macos-0.0.1+112.0.2
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.2
shared_preferences_windows-0.0.2+32.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-1.0.3+32.0.1+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
vin_decoder-0.1.4+10.1.4+1
win32-2.2.92.2.9
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 10 issues. Showing the first 2:

The constraint `^3.0.8` on dio does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

The constraint `^0.4.0+1` on firebase_performance does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions firebase_performance to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

0
likes
60
pub points
52%
popularity

Publisher

neomode.com.br

A Flutter package to access Neomode's API (LORI). The package encapsulates most of the complexity and provide an easy way to connect to the best omnichannel platform.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, dio, firebase_performance, flutter, flutter_phoenix, http, intl, json_annotation, path, shared_preferences, simple_rsa, sqflite, uuid, validators

More

Packages that depend on lori_sdk