loose 0.0.79 icon indicating copy to clipboard operation
loose: ^0.0.79 copied to clipboard

Library for working with Google Cloud Firestore in a server application.

0
likes
75/ 140
pub points
0%
popularity

We analyzed this package 1 hour ago, and awarded it 75 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
25 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

README.md is empty.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 302 API elements (2.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:loose/loose.dart that imports:
  • package:loose/src/write.dart that imports:
  • package:loose/src/loose.dart that imports:
  • package:googleapis_auth/auth_io.dart that imports:
  • package:googleapis_auth/src/oauth2_flows/metadata_server.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: Unused import: 'batch_get_result.dart'.

lib/src/commit_result.dart:1:8

  ╷
1 │ import 'batch_get_result.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/commit_result.dart

INFO: The import of 'document_info.dart' is unnecessary because all of the used elements are also provided by the import of 'package:loose/annotations.dart'.

lib/src/documenter.dart:2:8

  ╷
2 │ import 'document_info.dart';
  │        ^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/documenter.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
googleapis_auth^0.2.120.2.12+11.3.1
http^0.12.20.12.20.13.5
recase^3.0.03.0.14.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.17.01.17.0
crypto-3.0.23.0.2
http_parser-3.1.44.0.2
path-1.8.21.8.2
pedantic-1.11.11.11.1
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint ^0.2.12 on googleapis_auth does not support the stable version 1.0.0.

Try running dart pub upgrade --major-versions googleapis_auth to update the constraint.

The constraint ^0.12.2 on http does not support the stable version 0.13.0.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.8.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

0
likes
75
pub points
0%
popularity

Publisher

unverified uploader

Library for working with Google Cloud Firestore in a server application.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

googleapis_auth, http, recase

More

Packages that depend on loose