logger_flutter 0.7.1
logger_flutter: ^0.7.1

Flutter Android iOS

Flutter extension for logger. Please go there for documentation.

24
likes
70 / 110
pub points
91 %
popularity

We analyzed this package on Dec 4, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 24 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:logger_flutter/logger_flutter.dart that imports:
  • package:logger_flutter/src/shake_detector.dart that imports:
  • package:sensors/sensors.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: This function has a return type of 'Color', but doesn't end with a return statement.

lib/src/ansi_parser.dart:102:9

    ╷
102 │   Color getColor(int colorCode, bool foreground) {
    │         ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/ansi_parser.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
logger^0.7.00.7.0+20.9.4
sensors^0.4.0+10.4.2+60.4.2+6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.7.0` on logger does not support the latest published version `0.9.4`

pubspec.yaml:14:11

   ╷
14 │   logger: ^0.7.0
   │           ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

24
likes
70
pub points
91%
popularity

Flutter extension for logger. Please go there for documentation.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

simonleier@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, logger, sensors

More

Packages that depend on logger_flutter