loggable_mixin 1.0.4
loggable_mixin: ^1.0.4

Dart native
Flutter Android iOS

Package provides variety loggers which can ease your development flow.

0
likes
50 / 110
pub points
16 %
popularity

We analyzed this package on Nov 22, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://gitlab.com/nogipx/flutter-loggable was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 10 API elements (10.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:loggable_mixin/loggable_mixin.dart that imports:
  • package:loggable_mixin/src/Loggable.dart that imports:
  • package:logger/logger.dart that imports:
  • package:logger/src/printers/simple_printer.dart that imports:
  • package:io/ansi.dart that imports:
  • package:io/src/ansi_code.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/loggable_mixin.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/Loggable.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.0.21.1.11.1.1
logger^0.8.30.8.30.9.4
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
io-0.3.40.3.4
meta-1.2.41.2.4
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.8.3` on logger does not support the latest published version `0.9.4`

pubspec.yaml:10:11

   ╷
10 │   logger: ^0.8.3
   │           ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
50
pub points
16%
popularity

Publisher

dart.nogipx.ru

Package provides variety loggers which can ease your development flow.

Repository (GitLab)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ansicolor, logger

More

Packages that depend on loggable_mixin