- enhance: 地图移动结束动画在获取到poi之前执行
- enhance: 更新依赖
- 拆分widget, 引入BLoC架构
Demonstrates how to use the location_picker_fluttify plugin.
Getting Started #
This project is a starting point for a Flutter application.
A few resources to get you started if this is your first Flutter project:
For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: location_picker_fluttify: ^0.0.3
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.0
- pana: 0.13.4
- Flutter: 1.12.13+hotfix.5
lib/src/ui/widget/visual/decorated/decorated_flex.widget.dart. (-0.50 points)
lib/src/ui/widget/visual/decorated/decorated_flex.widget.dart reported 1 hint:
line 303 col 32: This function has a return type of 'SizedBox', but doesn't end with a return statement.
lib/src/ui/widget/visual/preferred/free/free_check_box.widget.dart. (-0.50 points)
lib/src/ui/widget/visual/preferred/free/free_check_box.widget.dart reported 1 hint:
line 49 col 10: The value of the local variable 'size' isn't used.
lib/src/utils/bloc/bloc_provider.widget.dart. (-0.50 points)
lib/src/utils/bloc/bloc_provider.widget.dart reported 1 hint:
line 28 col 17: 'ancestorInheritedElementForWidgetOfExactType' is deprecated and shouldn't be used. Use getElementForInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..
Maintenance issues and suggestions
Support latest dependencies. (-20 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 2 dependencies (
Package is pre-v0.1 release. (-10 points)
While nothing is inherently wrong with versions of
0.0.*, it might mean that the author is still experimenting with the general direction of the API.
The package description is too short. (-6 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
|Dart SDK||>=2.6.0 <3.0.0|