local_auth_windows 1.0.10 copy "local_auth_windows: ^1.0.10" to clipboard
local_auth_windows: ^1.0.10 copied to clipboard

PlatformWindows

Windows implementation of the local_auth plugin.

7
likes
150/ 160
pub points
95%
popularity

We analyzed this package 13 hours ago, and awarded it 150 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+local_auth%22 was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

23 out of 25 API elements (92.0 %) have documentation comments.

Some symbols that are missing documentation: auth_messages_windows, local_auth_windows.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:local_auth_windows/local_auth_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:local_auth_windows/local_auth_windows.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:local_auth_windows/local_auth_windows.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:local_auth_windows/local_auth_windows.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:local_auth_windows/local_auth_windows.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
local_auth_platform_interface ^1.0.1 1.0.10 1.0.10
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.