list_date_picker 1.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • new60

List Date Picker #

This package is based on this code showDatePicker. The showDatePicker return a DateTime, this package return a List<DateTime> so you can select multiple date.

Getting Started #

Show date picker which you can specify a list of date that allows users to choose.

List<DateTime> d = await showListDatePicker(
    context: context,
    initialDate: today,
    initialDate: DateTime.now(),
    firstDate: DateTime(DateTime.now().year - 1),
    lastDate: DateTime(DateTime.now().year + 1),
);

Authors #

  • Etienne Théodore theodoreetienne@gmail.com

list_date_picker

1.0.4 #

  • Remove plugin class in pubspec

1.0.3 #

  • Fix plugin class

1.0.2 #

  • Downgrade flutter to stable channel for pass errors from analysis

1.0.1 #

  • Short description

1.0.0 #

  • Adding linter

0.0.1 #

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:list_date_picker/list_date_picker.dart';

void main() {
  runApp(MaterialApp(home: MyApp()));
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: const Text('ListDatePicker'),
      ),
      body: Center(
        child: RaisedButton(
            child: Text('Show list date picker'),
            onPressed: () async {
              DateTime today = DateTime.now();

              List<DateTime> d = await showListDatePicker(
                context: context,
                initialDate: today,
                firstDate: today.add(Duration(days: -365)),
                lastDate: today.add(Duration(days: 365)),
              );
              // show the list of date selected
              print(d);
            }),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  list_date_picker: ^1.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:list_date_picker/list_date_picker.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
20
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
pedantic ^1.0.0