linksdk 3.3.1
linksdk: ^3.3.1 copied to clipboard

A new flutter plugin project.

example/lib/main.dart

import 'dart:io';

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:linksdk/linksdk.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';
  String _mobid = 'Unknown';

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    String mobid;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await Linksdk.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }

    try {
      mobid = await Linksdk.getMobId;
    } on PlatformException {
      mobid = 'Failed to get mobid.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
      _mobid = mobid;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('Running on: $_platformVersion\nMobId: $_mobid'),
        ),
      ),
    );
  }
}
0
likes
70
pub points
0%
popularity

A new flutter plugin project.

Homepage (insecure)

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on linksdk