lime 0.0.25 copy "lime: ^0.0.25" to clipboard
lime: ^0.0.25 copied to clipboard

LIME Protocol for Dart/Flutter - A lightweight messaging library

2
likes
130/ 160
pub points
4%
popularity

We analyzed this package 2 hours ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

209 out of 336 API elements (62.2 %) have documentation comments.

Some symbols that are missing documentation: lime, lime.Authentication.scheme, lime.AuthenticationSchemaExtension, lime.AuthenticationSchemaExtension.getValue, lime.ClientChannel.isForMe.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:lime/lime.dart that imports:
  • package:lime/src/protocol/network/web_socket_transport.dart that imports:
  • package:lime/src/protocol/network/transport.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

INFO: 'describeEnum' is deprecated and shouldn't be used. Use the `name` getter on enums instead. This feature was deprecated after v3.14.0-2.0.pre.

lib/src/protocol/command.dart:57:26

   ╷
57 │     command[methodKey] = describeEnum(method);
   │                          ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/protocol/command.dart

INFO: 'describeEnum' is deprecated and shouldn't be used. Use the `name` getter on enums instead. This feature was deprecated after v3.14.0-2.0.pre.

lib/src/protocol/command.dart:76:28

   ╷
76 │       command[statusKey] = describeEnum(status!);
   │                            ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/protocol/command.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
pretty_json ^2.0.0 2.0.0 2.0.0
simple_logger ^1.9.0 1.9.0+3 1.9.0+3
uuid ^3.0.5 3.0.7 4.4.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
stack_trace - 1.11.1 1.11.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.5` on uuid does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions uuid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
130
pub points
4%
popularity

Publisher

verified publisherblip.ai

LIME Protocol for Dart/Flutter - A lightweight messaging library

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, pretty_json, simple_logger, uuid

More

Packages that depend on lime