libao 0.2.0 copy "libao: ^0.2.0" to clipboard
libao: ^0.2.0 copied to clipboard

A Dart wrapper for the libao library to output audio using a simple API on a wide variety of platforms.

17
likes
80/ 140
pub points
20%
popularity

We analyzed this package 4 days ago, and awarded it 80 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

24 out of 25 API elements (96.0 %) have documentation comments.

Some symbols that are missing documentation: audio.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:libao/libao.dart that imports:
  • package:libao/src/native.dart that imports:
  • package:ffi/ffi.dart that imports:
  • package:ffi/src/utf16.dart that imports:
  • dart:ffi
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 27 issues. Showing the first 2:

ERROR: Fields in struct classes can't have the type 'int?'. They can only be declared as 'int', 'double', 'Array', 'Pointer', or subtype of 'Struct' or 'Union'.

lib/src/native.dart:18:3

   ╷
18 │   int? type;
   │   ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/native.dart

ERROR: Fields of 'Struct' and 'Union' subclasses must be marked external.

lib/src/native.dart:18:8

   ╷
18 │   int? type;
   │        ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/native.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^1.1.2 1.2.1 2.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.2` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

17
likes
80
pub points
20%
popularity

Publisher

verified publishertiagohm.dev

A Dart wrapper for the libao library to output audio using a simple API on a wide variety of platforms.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi

More

Packages that depend on libao