lefthook 0.6.5
lefthook: ^0.6.5 copied to clipboard

Dart

Fast and powerful Git hooks manager for any type of projects.

0
likes
55 / 110
pub points
21 %
popularity

We analyzed this package on Jan 26, 2021, and awarded it 55 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: Unnecessary new keyword.

bin/lefthook.dart:12:18

   ╷
12 │   final logger = new Logger.standard();
   │                  ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/lefthook.dart

INFO: Unnecessary new keyword.

bin/lefthook.dart:26:19

   ╷
26 │   Logger logger = new Logger.standard();
   │                   ^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer bin/lefthook.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.102.0.132.0.13
cli_util^0.1.3+20.1.40.2.0
system_info^0.1.10.1.30.1.3
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.01.6.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
file_utils-0.1.40.1.4
globbing-0.3.10.3.1
path-1.7.01.7.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.1.3+2` on cli_util does not support the latest published version `0.2.0`

pubspec.yaml:11:13

   ╷
11 │   cli_util: ^0.1.3+2
   │             ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
55
pub points
21%
popularity

Fast and powerful Git hooks manager for any type of projects.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

garik.novel@gmail.com

License

MIT (LICENSE)

Dependencies

archive, cli_util, system_info

More

Packages that depend on lefthook