leancloud_official_plugin 1.0.1 copy "leancloud_official_plugin: ^1.0.1" to clipboard
leancloud_official_plugin: ^1.0.1 copied to clipboard

An official flutter plugin for LeanCloud real-time message service based on LeanCloud-Swift-SDK and LeanCloud-Java-SDK.

9
likes
130/ 140
pub points
58%
popularity

We analyzed this package 6 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

196 out of 230 API elements (85.2 %) have documentation comments.

Some symbols that are missing documentation: leancloud_plugin, leancloud_plugin.Client.call, leancloud_plugin.Client.errorFrom, leancloud_plugin.Client.isFailure, leancloud_plugin.Client.parseIsoString.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:leancloud_official_plugin/leancloud_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:leancloud_official_plugin/leancloud_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:leancloud_official_plugin/leancloud_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:leancloud_official_plugin/leancloud_plugin.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: The import of 'dart:typed_data' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/services.dart'.

lib/leancloud_plugin.dart:4:8

  ╷
4 │ import 'dart:typed_data';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/leancloud_plugin.dart

INFO: The part-of directive uses a library name.

lib/src/client.dart:1:1

  ╷
1 │ part of leancloud_plugin;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/client.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
intl >=0.17.0 <1.0.0 0.19.0 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

9
likes
130
pub points
58%
popularity

Publisher

verified publisherleancloud.rocks

An official flutter plugin for LeanCloud real-time message service based on LeanCloud-Swift-SDK and LeanCloud-Java-SDK.

Homepage

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

flutter, intl

More

Packages that depend on leancloud_official_plugin