lazy_load_scrollview 1.3.0 copy "lazy_load_scrollview: ^1.3.0" to clipboard
lazy_load_scrollview: ^1.3.0 copied to clipboard

A wrapper for a ScrollView that will trigger a callback when the bottom of the page is reached

409
likes
130/ 140
pub points
97%
popularity

We analyzed this package 7 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

11 out of 17 API elements (64.7 %) have documentation comments.

Some symbols that are missing documentation: lazy_load_scrollview, lazy_load_scrollview.LazyLoadScrollViewState, lazy_load_scrollview.LazyLoadScrollViewState.LazyLoadScrollViewState, lazy_load_scrollview.LazyLoadScrollViewState.loadMoreStatus, lazy_load_scrollview.LoadingStatus.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: Use the generic function type syntax in 'typedef's.

lib/src/lazy_load_scrollview.dart:8:14

  ╷
8 │ typedef void EndOfPageListenerCallback();
  │              ^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/lazy_load_scrollview.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

409
likes
130
pub points
97%
popularity

Publisher

verified publisherquirijngb.com

A wrapper for a ScrollView that will trigger a callback when the bottom of the page is reached

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-2-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on lazy_load_scrollview