This library supports both, the "Haversine" and the "Vincenty" algorithm.
"Haversine" is a bit faster but "Vincenty" is far more accurate!
Catmull-Rom algorithm is used for smoothing out the path.
final Distance distance = new Distance(); // km = 423 final int km = distance.as(LengthUnit.Kilometer, new LatLng(52.518611,13.408056),new LatLng(51.519475,7.46694444)); // meter = 422591.551 final int meter = distance( new LatLng(52.518611,13.408056), new LatLng(51.519475,7.46694444) );
final Distance distance = const Distance(); final num distanceInMeter = (EARTH_RADIUS * math.PI / 4).round(); final p1 = new LatLng(0.0, 0.0); final p2 = distance.offset(p1, distanceInMeter, 180); // LatLng(latitude:-45.219848, longitude:0.0) print(p2.round()); // 45° 13' 11.45" S, 0° 0' 0.00" O print(p2.toSexagesimal());
// zigzag is a list of coordinates final Path path = new Path.from(zigzag); // Result is below final Path steps = path.equalize(8,smoothPath: true);
Please file feature requests and bugs at the issue tracker.
Copyright 2015 Michael Mitterer (email@example.com), IT-Consulting and Development Limited, Austrian Branch Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.
If this plugin is helpful for you - please (Circle) me or star this repo here on GitHub
Lightweight library for common latitude and longitude calculation
This CHANGELOG.md was generated with Changelog for Dart
Add this to your package's pubspec.yaml file:
dependencies: latlong: ^0.5.3
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.6.1||Aug 29, 2018|
|0.5.3||Jun 6, 2018|
|0.4.5||Dec 13, 2017|
|0.4.3||Dec 13, 2017|
|0.4.1||Dec 13, 2017|
|0.3.4||Nov 16, 2016|
|0.3.3||Oct 13, 2016|
|0.3.2||Feb 4, 2016|
|0.3.1||Feb 3, 2016|
|0.3.0||Jan 29, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.8.0 <2.0.0|