laconic 0.0.1 copy "laconic: ^0.0.1" to clipboard
laconic: ^0.0.1 copied to clipboard

A laravel like sql query builder for mysql designed to be flexible, portable and easy to use.

1
likes
120/ 140
pub points
16%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://laconic.antdf.xyz was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

36 out of 53 API elements (67.9 %) have documentation comments.

Some symbols that are missing documentation: laconic, laconic.Aggregate, laconic.Aggregate.Aggregate, laconic.DB, laconic.DB.DB.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:laconic/laconic.dart that imports:
  • package:laconic/src/query_builder.dart that imports:
  • package:laconic/src/db.dart that imports:
  • package:mysql1/mysql1.dart that imports:
  • package:mysql1/src/results/row.dart that imports:
  • package:mysql1/src/buffer.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
mysql1 ^0.19.2 0.19.2 0.20.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
logging - 1.2.0 1.2.0
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
pool - 1.5.1 1.5.1
stack_trace - 1.11.1 1.11.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.19.2` on mysql1 does not support the stable version `0.20.0`.

Try running dart pub upgrade --major-versions mysql1 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

1
likes
120
pub points
16%
popularity

Publisher

verified publishercals.xyz

A laravel like sql query builder for mysql designed to be flexible, portable and easy to use.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

mysql1

More

Packages that depend on laconic