koin_test 0.11.2

  • Readme
  • Changelog
  • Installing
  • 61

koin_test #

Build Status codecov

A testing library for koin.dart.

0.11.2 #

  • Updated to koin version 0.10.0.

0.11.1 #

  • Change koin version.
  • Added tests

0.11.0 #

  • Added support koin v0.8.0

0.10.0 #

  • Restructuring to support koin v0.7.2

0.7.0 #

  • Added extension functions to module test
  • Update readme
  • Renamed moduleTest to testModule
  • Renamed modulesTest to testModules

0.5.0 #

  • Added functions to improve koin tests.
    • koinTest Configures the testing environment to automatically start and `close Koin.
    • koinSetUp Register a setUp function that starts koin before tests.
    • koinTearDown Register a tearDown function that close Koin afters tests.
    • inject Lazy inject an instance from Koin in the test environment.
    • get Get an instance from Koin in the test environment.
  • Support for koin 0.2.0

0.2.0 #

  • Support for koin 0.2.0

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  koin_test: ^0.11.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:koin_test/koin_test.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
31
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
61
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14

Health suggestions

Format lib/src/check/check_module_dsl.dart.

Run dartfmt to format lib/src/check/check_module_dsl.dart.

Format lib/src/mock/declare.dart.

Run dartfmt to format lib/src/mock/declare.dart.

Format lib/src/mock/declare_mock.dart.

Run dartfmt to format lib/src/mock/declare_mock.dart.

Format lib/src/module_test.dart.

Run dartfmt to format lib/src/module_test.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and koin_test.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
equatable ^1.0.0 1.2.0
koin ^0.10.0 0.10.0
kt_dart ^0.7.0+1 0.7.0+1 0.8.0-dev.1
meta ^1.1.6 1.2.2 1.3.0-nullsafety
test ^1.6.0 1.15.2
Transitive dependencies
_fe_analyzer_shared 5.0.0
analyzer 0.39.12
args 1.6.0
async 2.4.2
boolean_selector 2.0.0
charcode 1.1.3
collection 1.14.13 1.15.0-nullsafety
convert 2.1.1
coverage 0.14.0
crypto 2.1.5
csslib 0.16.1
glob 1.2.0
html 0.14.0+3
http 0.12.1
http_multi_server 2.2.0
http_parser 3.1.4
io 0.3.4
js 0.6.2
logging 0.11.4
matcher 0.12.8
mime 0.9.6+3
node_interop 1.1.1
node_io 1.1.1
node_preamble 1.4.12
package_config 1.9.3
path 1.7.0
pool 1.4.0
pub_semver 1.4.4
shelf 0.7.7
shelf_packages_handler 2.0.0
shelf_static 0.2.8
shelf_web_socket 0.2.3
source_map_stack_trace 2.0.0
source_maps 0.10.9
source_span 1.7.0
stack_trace 1.9.5
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.17
test_core 0.3.10
typed_data 1.2.0 1.3.0-nullsafety
vm_service 4.1.0
watcher 0.9.7+15
web_socket_channel 1.1.0
webkit_inspection_protocol 0.7.3
yaml 2.2.1
Dev dependencies
mockito ^4.1.1
pedantic ^1.8.0 1.9.2