kohana 1.0.7+8
kohana: ^1.0.7+8 copied to clipboard

State management (flutter_hooks based), validators, common models, event bus, responsive layout and more in one codebase.

0
likes
60 / 130
pub points
39 %
popularity

We analyzed this package on May 8, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 33 out of 388 API elements (8.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:kohana/kohana.dart that imports:
  • package:kohana/kohana_ui.dart that imports:
  • package:kohana/src/navigation/base_navigator.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

lib/src/annotations.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/base_controller.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
daggerito^1.0.81.0.8+51.0.8+5
equatable^1.0.01.2.62.0.0
flutterflutter0.0.00.0.0
flutter_hooks^0.8.00.8.0+10.16.0
kohana_annotations^0.1.00.1.00.1.0
routex^1.0.101.0.101.0.10
rxdart^0.23.10.23.10.27.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.0.0` on equatable does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions equatable to update the constraint.

The constraint `^0.8.0` on flutter_hooks does not support the stable version `0.9.0`.

Try running dart pub upgrade --major-versions flutter_hooks to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

0
likes
60
pub points
39%
popularity

State management (flutter_hooks based), validators, common models, event bus, responsive layout and more in one codebase.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

s.nazdrajic@gmail.com

License

BSD (LICENSE)

Dependencies

daggerito, equatable, flutter, flutter_hooks, kohana_annotations, routex, rxdart

More

Packages that depend on kohana