knox_sdk 0.1.1 copy "knox_sdk: ^0.1.1" to clipboard
knox_sdk: ^0.1.1 copied to clipboard

Knox Networks Dart SDK

1
likes
120/ 160
pub points
0%
popularity

We analyzed this package 24 hours ago, and awarded it 120 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://developers.knoxnetworks.io/getting-started was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

46 out of 187 API elements (24.6 %) have documentation comments.

Some symbols that are missing documentation: knox_sdk.CPacket, knox_sdk.CPacket.CPacket, knox_sdk.CPacket.inner, knox_sdk.CPacket_t, knox_sdk.CProxy.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:knox_sdk/knox_sdk.dart that imports:
  • package:knox_sdk/src/utils.dart that imports:
  • package:knox_sdk/src/monetae_ffi.dart that imports:
  • dart:ffi
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 166 issues. Showing the first 2:

WARNING: The value of the field '__mbstate8' isn't used.

lib/src/monetae_ffi.dart:193:32

    ╷
193 │   external ffi.Array<ffi.Int8> __mbstate8;
    │                                ^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/monetae_ffi.dart

WARNING: The value of the field '_mbstateL' isn't used.

lib/src/monetae_ffi.dart:196:16

    ╷
196 │   external int _mbstateL;
    │                ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/monetae_ffi.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^1.1.2 1.2.1 2.1.2
fixnum ^1.0.0 1.1.0 1.1.0
flat_buffers ^2.0.5 2.0.5 23.5.26
path ^1.8.0 1.9.0 1.9.0
protobuf ^2.0.1 2.1.0 3.1.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0
meta - 1.15.0 1.15.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.1.2` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint `^2.0.5` on flat_buffers does not support the stable version `23.5.26`.

Try running dart pub upgrade --major-versions flat_buffers to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.