kevin_flutter_accounts_platform_interface 1.2.0 copy "kevin_flutter_accounts_platform_interface: ^1.2.0" to clipboard
kevin_flutter_accounts_platform_interface: ^1.2.0 copied to clipboard

PlatformAndroidiOS
unlisted

A common platform interface for the kevin_flutter_accounts plugin.

0
likes
120/ 140
pub points
4%
popularity

We analyzed this package 8 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 42 API elements (4.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: kevin_flutter_accounts_platform_interface, kevin_flutter_accounts_platform_interface.KevinAccountSessionConfiguration, kevin_flutter_accounts_platform_interface.KevinAccountSessionConfiguration.KevinAccountSessionConfiguration, kevin_flutter_accounts_platform_interface.KevinAccountSessionConfiguration.bankFilter, kevin_flutter_accounts_platform_interface.KevinAccountSessionConfiguration.countryFilter.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:kevin_flutter_accounts_platform_interface/kevin_flutter_accounts_platform_interface.dart that imports:
  • package:kevin_flutter_accounts_platform_interface/src/model/kevin_accounts_models.dart that imports:
  • package:kevin_flutter_accounts_platform_interface/src/model/kevin_session_result_account_success.dart that imports:
  • package:kevin_flutter_core/kevin_flutter_core.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:kevin_flutter_accounts_platform_interface/kevin_flutter_accounts_platform_interface.dart that imports:
  • package:kevin_flutter_accounts_platform_interface/src/model/kevin_accounts_models.dart that imports:
  • package:kevin_flutter_accounts_platform_interface/src/model/kevin_session_result_account_success.dart that imports:
  • package:kevin_flutter_core/kevin_flutter_core.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:kevin_flutter_accounts_platform_interface/kevin_flutter_accounts_platform_interface.dart that imports:
  • package:kevin_flutter_accounts_platform_interface/src/model/kevin_accounts_models.dart that imports:
  • package:kevin_flutter_accounts_platform_interface/src/model/kevin_session_result_account_success.dart that imports:
  • package:kevin_flutter_core/kevin_flutter_core.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:kevin_flutter_accounts_platform_interface/kevin_flutter_accounts_platform_interface.dart that imports:
  • package:kevin_flutter_accounts_platform_interface/src/model/kevin_accounts_models.dart that imports:
  • package:kevin_flutter_accounts_platform_interface/src/model/kevin_session_result_account_success.dart that imports:
  • package:kevin_flutter_core/kevin_flutter_core.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
kevin_flutter_core ^1.2.0 1.2.0 1.2.0
plugin_platform_interface ^2.1.3 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
kevin_flutter_core_android - 1.2.0 1.2.0
kevin_flutter_core_ios - 1.2.0 1.2.0
kevin_flutter_core_platform_interface - 1.1.0 1.1.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.