keen 0.1.0-alpha.1
keen: ^0.1.0-alpha.1 copied to clipboard

Keen is a minimalist and opinionated real-time server written in Dart.

0
likes
70 / 110
pub points
0 %
popularity

We analyzed this package on Apr 14, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/aloisdeniel/keen was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 60 out of 236 API elements (25.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:keen/client.dart that imports:
  • package:keen/src/client/auth/encryption.dart that imports:
  • package:aes_crypt/aes_crypt.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

INFO: Unused import: 'dart:io'.

lib/src/client/auth/auth.dart:2:8

  ╷
2 │ import 'dart:io';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/client/auth/auth.dart

INFO: Unused import: 'package:aes_crypt/aes_crypt.dart'.

lib/src/client/auth/auth.dart:4:8

  ╷
4 │ import 'package:aes_crypt/aes_crypt.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/client/auth/auth.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
aes_crypt^0.1.10.1.10.1.1
crypto^2.1.52.1.53.0.1
freezed_annotation^0.12.00.12.00.14.1
http^0.12.20.12.20.13.1
json_annotation^3.1.03.1.14.0.1
mailer^3.2.13.3.05.0.0
meta^1.0.01.3.01.3.0
pedantic^1.9.01.11.01.11.0
postgres^2.2.02.2.02.3.2
uuid^2.2.22.2.23.0.4
web_socket_channel^1.1.01.2.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
buffer-1.1.11.1.1
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
http_parser-3.1.44.0.0
intl-0.17.00.17.0
logging-0.11.41.0.1
mime-0.9.71.0.0
path-1.8.01.8.0
source_span-1.8.11.8.1
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^2.1.5` on crypto does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^0.12.0` on freezed_annotation does not support the stable version `0.14.0`.

Try running dart pub upgrade --major-versions freezed_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.