kana_kit 2.0.0
kana_kit: ^2.0.0 copied to clipboard

A Dart library for for detecting and transliterating Hiragana, Katakana, and Romaji.

2.0.0 #

  • Add NNBD support.
  • Change minimum required Dart version to 2.12.0.
  • Change linter to package:very_good_analysis.
  • Upgrade package:equatable to 2.0.0
  • Upgrade all dev dependencies.

1.0.4 #

  • Upgrade package:equatable to 1.2.3
  • Fix dartdoc warnings caused by equatable.

1.0.3+3 #

  • Add library level documentation comment.
  • Minor README change.
  • Move test dependency to dev_dependencies.

1.0.3+2 #

  • Add example.
  • Replace publishing CI step with custom script.
  • Remove homepage from pubspec.
  • Minor README change.

1.0.3 #

  • Add codecov.yml.
  • Change publish_to_pub workflow to run on GitHub release publishing.
  • Improve README format with fancy badge.
  • Improve CHANGELOG format for fancy new pub.dev.

1.0.2 #

  • Small CI/CD pipeline fix.

1.0.1 #

  • Initial pub release.
  • Improved README.
  • Added pub publishing CD workflow.

1.0.0 #

  • Initial release 🎉
12
likes
130
pub points
81%
popularity

Publisher

jfk.dev

A Dart library for for detecting and transliterating Hiragana, Katakana, and Romaji.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable

More

Packages that depend on kana_kit