k_responsive 0.2.1 copy "k_responsive: ^0.2.1" to clipboard
k_responsive: ^0.2.1 copied to clipboard

A standard responsive, and customizable plugin everything to usage

7
likes
130/ 160
pub points
0%
popularity

We analyzed this package 13 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

18 out of 56 API elements (32.1 %) have documentation comments.

Some symbols that are missing documentation: k_responsive, k_responsive.DeviceType, k_responsive.DoubleResponsive, k_responsive.DoubleResponsive.f, k_responsive.DoubleResponsive.fSafe.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

WARNING: Duplicate export.

lib/k_responsive.dart:6:8

  ╷
6 │ export 'src/k_responsive_builder.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/k_responsive.dart

INFO: A value for optional parameter 'context' isn't ever given.

lib/src/k_resource.dart:8:21

  ╷
8 │   KResource._({this.context,this.designSize = Size.zero,this.responsive =const  KResponsiveObject()});
  │                     ^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/k_resource.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

7
likes
130
pub points
0%
popularity

Publisher

unverified uploader

A standard responsive, and customizable plugin everything to usage

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (license)

Dependencies

flutter

More

Packages that depend on k_responsive