jyou_sdk 0.3.9 copy "jyou_sdk: ^0.3.9" to clipboard
jyou_sdk: ^0.3.9 copied to clipboard

Jyou SDK Flutter Plugin

0
likes
130/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://kakzaki.my.id was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: CPL-1.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

54 out of 57 API elements (94.7 %) have documentation comments.

Some symbols that are missing documentation: jyou_sdk, jyou_sdk.JyouSdk, jyou_sdk.JyouSdk.JyouSdk.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:jyou_sdk/jyou_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:jyou_sdk/jyou_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:jyou_sdk/jyou_sdk.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:jyou_sdk/jyou_sdk.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

0
likes
130
pub points
0%
popularity

Publisher

verified publisherkakzaki.dev

Jyou SDK Flutter Plugin

Homepage

Documentation

API reference

License

CPL-1.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on jyou_sdk