jw_video_player 0.0.2 copy "jw_video_player: ^0.0.2" to clipboard
jw_video_player: ^0.0.2 copied to clipboard

A flutter plugin for the JWPlayer platform.

4
likes
100/ 140
pub points
57%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Repository URL doesn't exist.

At the time of the analysis https://github.com/DavidPerezP124/jwplayer_plugin/tree/main was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

49 out of 217 API elements (22.6 %) have documentation comments.

Some symbols that are missing documentation: dart_ui, dart_ui_devices, dart_ui_html, dart_ui_html.platformViewRegistry, dart_ui_html.platformViewRegistry.platformViewRegistry.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:jw_video_player/configuration/jwplayer_configuration.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:jw_video_player/configuration/jwplayer_configuration.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:jw_video_player/configuration/jwplayer_configuration.dart that declares support for platforms: Android, iOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Android

Because:

  • package:jw_video_player/shims/dart_ui.dart that imports:
  • package:jw_video_player/shims/dart_ui_html.dart that imports:
  • dart:html
Package not compatible with platform iOS

Because:

  • package:jw_video_player/shims/dart_ui.dart that imports:
  • package:jw_video_player/shims/dart_ui_html.dart that imports:
  • dart:html
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

WARNING: This API is available since SDK 2.14.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/jwplayer_platform_interface.dart:142:30

    ╷
142 │   int get hashCode => Object.hash(eventType, duration, size, position);
    │                              ^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/jwplayer_platform_interface.dart

WARNING: This API is available since SDK 2.14.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/jwplayer_platform_interface.dart:142:56

    ╷
142 │   int get hashCode => Object.hash(eventType, duration, size, position);
    │                                                        ^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/jwplayer_platform_interface.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
js ^0.6.4 0.6.7 0.7.1
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.4` on js does not support the stable version `0.7.0`.

Try running dart pub upgrade --major-versions js to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

4
likes
100
pub points
57%
popularity

Publisher

unverified uploader

A flutter plugin for the JWPlayer platform.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, flutter_web_plugins, js, plugin_platform_interface

More

Packages that depend on jw_video_player