jverify 0.5.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 78

QQ Group

JVerify Flutter Plugin #

安装 #

在工程 pubspec.yaml 中加入 dependencies

//pub 集成
  jverify: 0.5.2

//github 集成  
      url: git://github.com/jpush/jverify-flutter-plugin.git
      ref: master

配置 #

Android: #

/android/app/build.gradle 中添加下列代码:

android: {
  defaultConfig {
    applicationId "替换成自己应用 ID"
    ndk {
	//选择要添加的对应 cpu 类型的 .so 库。
	abiFilters 'armeabi', 'armeabi-v7a', 'x86', 'x86_64', 'mips', 'mips64', 'arm64-v8a',        

    manifestPlaceholders = [
        JPUSH_PKGNAME : applicationId,
        JPUSH_APPKEY : "appkey", // NOTE: JPush 上注册的包名对应的 Appkey.
        JPUSH_CHANNEL : "developer-default", //暂时填写默认值即可.

使用 #

import 'package:jverify/jverify.dart';

APIs #

注意 : 需要先调用 Jverify.setup 来初始化插件,才能保证其他功能正常工作。


0.5.2 #

  • 修复:授权登录回调通知 bug

0.5.1 #

  • 修复:iOS 授权页 loading 框位置偏移问题
  • 修复:iOS 授权页监听点击事件 bug
  • 同步 JVerification SDK 2.5.0 版本

0.5.0 #

  • 新增:一键登录的同步接口 [loginAuthSyncApi]

0.4.0 #

  • 新增:一键登录接口(loginAuth)返回数据支持添加监听获取 [addLoginAuthCallBackListener],具体使用查看 API 文档或者 demo 样例;

0.3.0 #

  • 新增:关闭授权页面接口

0.2.0 #

  • 新增:设置授权页背景图片
  • 新增:支持隐藏导航栏、返回按钮

0.1.0 #

  • 新增:SDK 清除预取号缓存接口
  • 新增:可设置横竖屏授权页接口
  • 新增:授权页点击事件监听
  • sdk 适配到 v2.4.8

0.0.5 #

  • fix 1、修复:自定义 UI 时传入无资源的图片导致错误问题; 2、修复:自定义 UI 时不传 widgets 导致错误问题; 3、SDK 适配到 v2.3.6

0.0.4 #

  • fix 1、新增:添加自定义 Textview 控件; 2、新增:添加自定义 Button 控件; 3、新增:设置协议勾选框默认状态属性; 4、变更:自定义 UI 界面接口将使用新接口 [setCustomAuthViewAllWidgets],具体使用查看 API 文档或者 demo 样例;

0.0.3 #

  • fix 1、修复与微信插件 fluwx 命名冲突问题;

0.0.2 #

  • fix 1、适配最新版本的认证 SDK; 2、修复 bug;

0.0.1 #

official release.


jverify_example #

Demonstrates how to use the jverify plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jverify: ^0.5.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:jverify/jverify.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/jverify.dart. (-1.99 points)

Analysis of lib/jverify.dart reported 4 hints:

line 42 col 16: Name non-constant identifiers using lowerCamelCase.

line 47 col 18: The value of the field '_platform' isn't used.

line 455 col 18: The type parameter 'widgetId' is annotated with @required but only named parameters without default value can be annotated with it.

line 455 col 43: The type parameter 'type' is annotated with @required but only named parameters without default value can be annotated with it.

Maintenance suggestions

The package description is too short. (-2 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
platform ^2.0.0 2.2.1
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies