jt_firebase_flutter 0.1.0+1
jt_firebase_flutter: ^0.1.0+1

Flutter Android iOS

A wrapper of firebase_database to provide unified API.

0
likes
60 / 110
pub points
10 %
popularity

We analyzed this package on Dec 1, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://jtzell.com was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 52 API elements (7.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:jt_firebase_flutter/jt_firebase_flutter.dart that imports:
  • package:jt_firebase_flutter/src/reference.dart that imports:
  • package:jt_firebase_flutter/src/query.dart that imports:
  • package:jt_firebase_flutter/src/data_snapshot.dart that imports:
  • package:firebase_database/firebase_database.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
firebase_core^0.4.40.4.50.5.2+1
firebase_database^3.1.53.1.64.3.0
jt_firebase^0.1.00.1.0+10.1.0+1
meta^1.1.81.3.0-nullsafety.61.3.0-nullsafety.6
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.5.0-nullsafety.3
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
crypto_keys-0.1.30.1.3
dart2_constant-1.0.2+dart21.0.2+dart2
firebase-7.3.27.3.2
firebase_core_platform_interface-1.0.42.1.0
firebase_core_web-0.1.1+20.2.1+1
firebase_dart-0.7.15+40.7.15+4
fixnum-0.10.110.10.11
http-0.12.20.12.2
http_parser-3.1.43.1.4
isolate-2.0.32.0.3
jose-0.1.2+10.2.1+1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
logging-0.11.40.11.4
matcher-0.12.90.12.10-nullsafety.3
path-1.7.01.8.0-nullsafety.3
pedantic-1.9.21.9.2
plugin_platform_interface-1.0.31.0.3
pointycastle-1.0.22.0.0
quiver-2.1.52.1.5
sortedmap-0.4.2+10.4.2+1
source_span-1.7.01.8.0-nullsafety.4
stack_trace-1.9.61.10.0-nullsafety.6
stream_channel-2.0.02.1.0-nullsafety.3
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
web_socket_channel-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.4` on firebase_core does not support the latest published version `0.5.2+1`

pubspec.yaml:14:18

   ╷
14 │   firebase_core: ^0.4.4
   │                  ^^^^^^
   ╵
The constraint `^3.1.5` on firebase_database does not support the latest published version `4.3.0`

pubspec.yaml:15:22

   ╷
15 │   firebase_database: ^3.1.5
   │                      ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
10%
popularity

Publisher

jtzell.com

A wrapper of firebase_database to provide unified API.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

firebase_core, firebase_database, flutter, jt_firebase, meta

More

Packages that depend on jt_firebase_flutter