jsonloader 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • new50

jsonloader #

JSON Loader Package to read JSON from asset.

Pub Version License

Logo Flutter JSON LOADER

Features #

  • Load and read JSON from assets.

Getting Started #

In the pubspec.yaml of your flutter project, add the following dependency:

dependencies:
  ...
  jsonloader: ^1.0.0

In your library add the following import:

import 'package:jsonloader/jsonloader.dart';

Super Simple To Use #

import 'package:jsonloader/jsonloader.dart';

void main() async {
  var jsonString = await JSONLoader().getJsonAsString('assets/login_response.json');
  print('jsonString: $jsonString');
}

[1.0.1] - 2020/21/6 #

  • Create the getJsonAsMap function to read the JSON file as Map object.

[1.0.0] - 2020/21/6 #

  • Initial Open Source release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:jsonloader/jsonloader.dart';

void main() => runApp(App());

class App extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: HomePage(),
    );
  }
}

class HomePage extends StatefulWidget {
  @override
  _HomePageState createState() => _HomePageState();
}

class _HomePageState extends State<HomePage> {
  var result = '';

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('Demo'),
      ),
      body: Center(
        child: Column(
          mainAxisSize: MainAxisSize.min,
          mainAxisAlignment: MainAxisAlignment.center,
          children: [
            Text(result),
            Row(
              mainAxisAlignment: MainAxisAlignment.center,
              children: [
                RaisedButton(
                  child: Text('Read JSON As String'),
                  onPressed: () async {
                    result = await JSONLoader().getJsonAsString('assets/login_response.json');
                    setState(() {});
                  },
                ),
                SizedBox(width: 16),
                RaisedButton(
                  child: Text('Read JSON As Map'),
                  onPressed: () async {
                    var jsonMap = await JSONLoader().getJsonAsMap('assets/login_response.json');
                    result = jsonMap['message'];
                    setState(() {});
                  },
                ),
              ],
            ),
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  jsonloader: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:jsonloader/jsonloader.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 14, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • jsonloader that is a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test