json_to_model 3.2.4 copy "json_to_model: ^3.2.4" to clipboard
json_to_model: ^3.2.4 copied to clipboard

Generate model class from Json file.

45
likes
60/ 140
pub points
81%
popularity

We analyzed this package 3 days ago, and awarded it 60 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

3 out of 209 API elements (1.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: args_parser, args_parser.ArgumentParser, args_parser.ArgumentParser.ArgumentParser, args_parser.ArgumentParser.argParser, args_parser.ArgumentParser.arguments.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:json_to_model/json_to_model.dart that imports:
  • package:json_to_model/index.dart that imports:
  • dart:io
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

ERROR: The language version must be >=2.12.0.

bin/main.dart:1:1

  ╷
1 │ // @dart=2.10
  │ ^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze bin/main.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.0.0 2.4.2 2.4.2
logging ^1.0.1 1.2.0 1.2.0
path ^1.8.0 1.9.0 1.9.0
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.