json_to_dart 1.0.4
json_to_dart: ^1.0.4 copied to clipboard

A library that generates Dart classes (parse and generator included) from a json string.

3
likes
65 / 130
pub points
42 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 95 API elements (3.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:json_to_dart/json_to_dart.dart that imports:
  • package:json_to_dart/model_generator.dart that imports:
  • package:dart_style/dart_style.dart that imports:
  • package:dart_style/src/exceptions.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/sdk.dart that imports:
  • package:analyzer/dart/ast/visitor.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/type_system.dart that imports:
  • package:analyzer/src/dart/element/type_schema_elimination.dart that imports:
  • package:analyzer/src/dart/element/type_schema.dart that imports:
  • package:analyzer/src/dart/element/type_visitor.dart that imports:
  • package:analyzer/src/summary2/named_type_builder.dart that imports:
  • package:analyzer/src/summary2/lazy_ast.dart that imports:
  • package:analyzer/src/summary2/linked_unit_context.dart that imports:
  • package:analyzer/src/summary2/linked_bundle_context.dart that imports:
  • package:analyzer/src/summary2/linked_element_factory.dart that imports:
  • package:analyzer/src/dart/resolver/scope.dart that imports:
  • package:analyzer/src/dart/element/scope.dart that imports:
  • package:analyzer/src/context/source.dart that imports:
  • package:analyzer/src/workspace/package_build.dart that imports:
  • package:analyzer/src/workspace/workspace.dart that imports:
  • package:analyzer/src/workspace/bazel.dart that imports:
  • package:analyzer/src/summary/package_bundle_reader.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert^2.0.12.1.13.0.1
dart_style^1.0.101.3.122.0.3
json_ast^1.0.51.0.51.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.023.0.0
analyzer-0.41.22.0.0
args-2.2.02.2.0
async-2.8.12.8.1
charcode-1.3.11.3.1
cli_util-0.3.30.3.3
collection-1.15.01.15.0
crypto-3.0.13.0.1
file-6.1.26.1.2
glob-2.0.12.0.1
grapheme_splitter-1.0.01.0.0
meta-1.7.01.7.0
package_config-1.9.32.0.0
pedantic-1.11.11.11.1
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.1` on convert does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions convert to update the constraint.

The constraint `^1.0.10` on dart_style does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions dart_style to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

3
likes
65
pub points
42%
popularity

A library that generates Dart classes (parse and generator included) from a json string.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Unlicense (LICENSE)

Dependencies

convert, dart_style, json_ast

More

Packages that depend on json_to_dart