json_serializable_plus 0.0.3 icon indicating copy to clipboard operation
json_serializable_plus: ^0.0.3 copied to clipboard

Automatically generate code for converting json Unified,dependencies json_serializable .Look like Gson

1
likes
100/ 140
pub points
4%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 3 API elements (33.3 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: The import of 'package:build/src/asset/id.dart' is unnecessary because all of the used elements are also provided by the import of 'package:build/build.dart'.

lib/src/aggregate/aggregate_generator.dart:4:8

  ╷
4 │ import 'package:build/src/asset/id.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/aggregate/aggregate_generator.dart

INFO: The import of 'package:build/src/builder/build_step.dart' is unnecessary because all of the used elements are also provided by the import of 'package:build/build.dart'.

lib/src/aggregate/aggregate_generator.dart:6:8

  ╷
6 │ import 'package:build/src/builder/build_step.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/aggregate/aggregate_generator.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.41.10.41.25.4.0
build^1.6.01.6.22.3.1
build_config^0.4.50.4.71.1.1
dart_style^1.3.101.3.122.2.4
glob^1.2.01.2.12.1.1
json_annotation^3.1.13.1.14.8.0
meta^1.2.41.9.01.9.0
path^1.7.01.8.31.8.3
source_gen^0.9.10+10.9.10+31.2.7
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.052.0.0
args-2.3.22.3.2
async-2.10.02.10.0
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.2
cli_util-0.3.50.3.5
clock-1.1.11.1.1
collection-1.17.11.17.1
convert-3.1.13.1.1
crypto-3.0.23.0.2
file-5.2.16.1.4
intl-0.18.00.18.0
js-0.6.70.6.7
logging-1.1.11.1.1
node_interop-1.2.12.1.0
node_io-1.2.02.2.0
package_config-1.9.32.1.0
pedantic-1.11.11.11.1
pub_semver-2.1.32.1.3
pubspec_parse-0.1.81.2.1
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.21.0.2
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 7 issues. Showing the first 2:

The constraint `^0.41.1` on analyzer does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.6.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Dart 2.19.1.

1
likes
100
pub points
4%
popularity

Publisher

verified publisher iconhuangjiaqi.top

Automatically generate code for converting json Unified,dependencies json_serializable .Look like Gson

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

analyzer, build, build_config, dart_style, glob, json_annotation, meta, path, source_gen

More

Packages that depend on json_serializable_plus