json_serializable_dart 1.0.1
json_serializable_dart: ^1.0.1 copied to clipboard

Lightweigth dart lib for generating methods to read/write toJsonObject.

0
likes
90/ 130
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 13 API elements (38.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/builder.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/json_serializable_dart.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.3.01.7.22.8.0
build^2.1.02.1.12.1.1
source_genany1.0.31.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.031.0.0
args-2.3.02.3.0
async-2.8.22.8.2
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
dart_style-2.1.12.2.0
file-6.1.26.1.2
glob-2.0.22.0.2
logging-1.0.21.0.2
meta-1.7.01.7.0
package_config-2.0.22.0.2
path-1.8.01.8.0
pub_semver-2.1.02.1.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.11.0.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.3.0` on analyzer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
90
pub points
0%
popularity

Lightweigth dart lib for generating methods to read/write toJsonObject.

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, build, source_gen

More

Packages that depend on json_serializable_dart