json_screen 0.7.0+5 icon indicating copy to clipboard operation
json_screen: ^0.7.0+5 copied to clipboard

A widget builder by using json

1
likes
80/ 130
pub points
0%
popularity

We analyzed this package 18 hours ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 118 out of 304 API elements (38.8 %) have documentation comments.
icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:json_screen/json_screen.dart that imports:
  • package:json_screen/json_screen/views/json_screen.dart that imports:
  • package:json_screen/json_screen/models/utils.dart that imports:
  • package:story_view/story_view.dart that imports:
  • package:story_view/story_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:json_screen/json_screen.dart that imports:
  • package:json_screen/json_screen/views/json_screen.dart that imports:
  • package:json_screen/json_screen/models/utils.dart that imports:
  • package:story_view/story_view.dart that imports:
  • package:story_view/story_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:json_screen/json_screen.dart that imports:
  • package:json_screen/json_screen/views/json_screen.dart that imports:
  • package:json_screen/json_screen/models/utils.dart that imports:
  • package:story_view/story_view.dart that imports:
  • package:story_view/story_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/cache_manager.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:json_screen/json_screen.dart that imports:
  • package:json_screen/json_screen/views/json_screen.dart that imports:
  • package:json_screen/json_screen/models/utils.dart that imports:
  • package:story_view/story_view.dart that imports:
  • package:story_view/story_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/web/web_helper.dart that imports:
  • package:flutter_cache_manager/src/cache_store.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:json_screen/json_screen.dart that imports:
  • package:json_screen/json_screen/views/json_screen.dart that imports:
  • package:json_screen/json_screen/models/utils.dart that imports:
  • package:story_view/story_view.dart that imports:
  • package:story_view/story_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/cache_manager.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:json_screen/json_screen.dart that imports:
  • package:json_screen/json_screen/views/json_screen.dart that imports:
  • package:json_screen/json_screen/models/utils.dart that imports:
  • package:story_view/story_view.dart that imports:
  • package:story_view/story_image.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/cache_manager.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/json_screen/views/subviews/blocks/webview_view.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
carousel_slider^1.4.11.4.14.0.0
dio^3.0.93.0.104.0.4
flutterflutter0.0.00.0.0
json_schema_form^0.8.50.8.51.1.9+2
page_view_indicators^1.3.11.4.12.0.0
photo_view^0.9.20.9.20.13.0
story_view^0.11.40.11.50.13.2
timeline_list2^0.1.00.1.00.1.0
webview_flutter^0.3.19+90.3.243.0.0
xml^3.5.03.7.05.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
barcode_scan-2.0.23.0.1
characters-1.2.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_cache_manager-1.4.23.3.0
flutter_plugin_android_lifecycle-1.0.112.0.5
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
image_picker-0.6.7+220.8.4+5
image_picker_platform_interface-1.1.62.4.3
js-0.6.30.6.4
meta-1.7.01.7.0
nested-1.0.01.0.0
path-1.8.11.8.1
path_provider-1.6.282.0.8
path_provider_linux-0.0.1+22.1.5
path_provider_macos-0.0.4+82.0.5
path_provider_platform_interface-1.0.42.0.3
path_provider_windows-0.0.52.0.5
pedantic-1.11.11.11.1
permission_handler-4.4.0+hotfix.48.3.0
permission_handler_platform_interface-1.0.03.7.0
petitparser-3.1.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.2
process-4.2.44.2.4
progress_indicators-0.1.51.0.0
provider-4.3.36.0.2
rxdart-0.23.10.27.3
sky_engine-0.0.990.0.99
source_span-1.8.21.8.2
sqflite-1.3.2+42.0.2
sqflite_common-1.0.3+32.2.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5
vector_math-2.1.12.1.1
video_player-0.10.12+52.2.16
video_player_platform_interface-2.2.05.0.1
video_player_web-0.1.4+12.0.6
win32-2.3.82.3.8
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^1.4.1` on carousel_slider does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions carousel_slider to update the constraint.

The constraint `^3.0.9` on dio does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.