json_forms 1.0.1+7

Flutter Android iOS web

A Flutter package that generate the widgets corresponding to a form using a json file

0
likes
70 / 110
pub points
17 %
popularity

We analyzed this package on Sep 29, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 26 API elements (15.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
10 / 30

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

WARNING: The parameter 'create' is required.

lib/json_forms.dart:58:12

   ╷
58 │     return ChangeNotifierProvider<FormProvider>(
   │            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/json_forms.dart

INFO: 'builder' is deprecated and shouldn't be used. will be removed in 4.0.0, use create instead.

lib/json_forms.dart:59:9

   ╷
59 │         builder: (_) {
   │         ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/json_forms.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
json_annotation^3.0.03.1.03.1.0
provider^3.0.0+13.2.04.3.2+2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
collection-1.14.131.14.13
meta-1.1.81.2.3
sky_engine-0.0.990.0.99
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.0.0+1` on provider does not support the latest published version `4.3.2+2`

pubspec.yaml:12:13

   ╷
12 │   provider: ^3.0.0+1
   │             ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
17%
popularity

A Flutter package that generate the widgets corresponding to a form using a json file

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

lecuivre.alban@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, json_annotation, provider

More

Packages that depend on json_forms