json_extension 0.4.1

Dart native

Uses class_extensions and json_serializable to generate methods for object serialization from/to json map/string.

0
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:json_extension/json_extension.dart that imports:
  • package:json_extension/src/json_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.00.39.170.40.3
build>=0.12.6 <2.0.01.5.01.5.0
class_extensions^0.10.00.10.20.10.2
json_extension_annotations^0.3.00.3.00.3.0
source_gen^0.9.00.9.7+10.9.7+1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.010.0.0
args-1.6.01.6.0
async-2.4.22.4.2
charcode-1.1.31.1.3
class_extensions_annotations-0.2.00.2.0
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.7
glob-1.2.01.2.0
html-0.14.0+30.14.0+3
js-0.6.20.6.2
json_annotation-3.1.03.1.0
logging-0.11.40.11.4
meta-1.2.31.2.3
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.7.0
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.39.0` on analyzer does not support the latest published version `0.40.3`

pubspec.yaml:13:13

   ╷
13 │   analyzer: ^0.39.0
   │             ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
0%
popularity

Uses class_extensions and json_serializable to generate methods for object serialization from/to json map/string.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

svarzee@gmail.com

License

BSD (LICENSE)

Dependencies

analyzer, build, class_extensions, json_extension_annotations, source_gen

More

Packages that depend on json_extension