jdate 0.9.0 copy "jdate: ^0.9.0" to clipboard
jdate: ^0.9.0 copied to clipboard

Powerful yet original Dart Jalali date and time for developers.

13
likes
120/ 140
pub points
77%
popularity

We analyzed this package 41 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

68 out of 75 API elements (90.7 %) have documentation comments.

Some symbols that are missing documentation: jdate.PersianDateTimeHelper, jdate.PersianDateTimeHelper.toJDate, jdate.PersianIntegerHelper, jdate.PersianIntegerHelper.toPersianWords, jdate.PersianStringHelper.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/jdate_base.dart:939:17

    ╷
939 │   bool operator ==(dynamic other) =>
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/jdate_base.dart

INFO: Missing a corresponding override of 'hashCode'.

lib/src/basic_date.dart:25:17

   ╷
25 │   bool operator ==(other) {
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/basic_date.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

13
likes
120
pub points
77%
popularity

Publisher

verified publisheramiralitaheri.ir

Powerful yet original Dart Jalali date and time for developers.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

More

Packages that depend on jdate