jalali_date 0.1.1

  • README.md
  • Installing
  • Versions
  • 34

jalali_date #

Persian (Jalali) date for Dart (Web/Flutter/DartVm). This calendar is using in Iran, Afghanistan and other countries. with this plugin, you can convert Gregorian date to Persian date.

Usage #

void main(){
    //Create a date object from current time.
    PersianDate date = new PersianDate.now();

[0.0.1] - July 10 2018

  • Convert Gregorian date to Jalali date

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jalali_date: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:jalali_date/jalali_date.dart';
Version Uploaded Documentation Archive
0.1.5 May 4, 2019 Go to the documentation of jalali_date 0.1.5 Download jalali_date 0.1.5 archive
0.1.4 Apr 15, 2019 Go to the documentation of jalali_date 0.1.4 Download jalali_date 0.1.4 archive
0.1.3 Jan 1, 2019 Go to the documentation of jalali_date 0.1.3 Download jalali_date 0.1.3 archive
0.1.2 Jul 11, 2018 Go to the documentation of jalali_date 0.1.2 Download jalali_date 0.1.2 archive
0.1.1 Jul 10, 2018 Go to the documentation of jalali_date 0.1.1 Download jalali_date 0.1.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0