jalali_date 0.1.5

  • README.md
  • Example
  • Installing
  • Versions
  • 85

jalali_date #

Persian (Jalali) date for Dart (Web/Flutter/DartVm). This calendar is using in Iran, Afghanistan and other countries. with this plugin, you can convert Gregorian date to Persian date.

Usage #

void main(){
    //Create a date object from current time.
    PersianDate date = new PersianDate.now();

[0.0.1] - July 10 2018

  • Convert Gregorian date to Jalali date


import 'package:jalali_date/jalali_date.dart';

main(List<String> arguments) async {
  print(PersianDate.fromDateTime(DateTime.parse('2012-02-27 13:27:00.123456z'))
      .toString(showTime: true));
  print(PersianDate.now().toString(showTime: false));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jalali_date: ^0.1.5

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:jalali_date/jalali_date.dart';
Version Uploaded Documentation Archive
0.1.5 May 4, 2019 Go to the documentation of jalali_date 0.1.5 Download jalali_date 0.1.5 archive
0.1.4 Apr 15, 2019 Go to the documentation of jalali_date 0.1.4 Download jalali_date 0.1.4 archive
0.1.3 Jan 1, 2019 Go to the documentation of jalali_date 0.1.3 Download jalali_date 0.1.3 archive
0.1.2 Jul 11, 2018 Go to the documentation of jalali_date 0.1.2 Download jalali_date 0.1.2 archive
0.1.1 Jul 10, 2018 Go to the documentation of jalali_date 0.1.1 Download jalali_date 0.1.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies