jaguar_serializer_mongo 2.2.1
jaguar_serializer_mongo: ^2.2.1

Dart native
Flutter Android iOS

MongoDB serializer helpers for jaguar_serializer

0
likes
60 / 110
pub points
10 %
popularity

We analyzed this package on Dec 4, 2020, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 17 API elements (41.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:jaguar_serializer_mongo/jaguar_serializer_mongo.dart that imports:
  • package:mongo_dart/mongo_dart.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Unnecessary new keyword.

lib/jaguar_serializer_mongo.dart:21:12

   ╷
21 │     return new mgo.ObjectId.fromHexString(value);
   │            ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/jaguar_serializer_mongo.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
jaguar_serializer^2.2.62.2.122.2.12
mongo_dart^0.3.20.3.60.4.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
bson-0.3.40.3.4
characters-1.0.01.0.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
fixnum-0.10.110.10.11
logging-0.11.40.11.4
meta-1.2.41.2.4
mongo_dart_query-0.3.20.4.2
more-2.8.02.8.0
path-1.7.01.7.0
pool-1.4.01.4.0
rational-0.3.80.3.8
stack_trace-1.9.61.9.6
typed_data-1.2.01.2.0
uuid-2.2.22.2.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.2` on mongo_dart does not support the latest published version `0.4.4`

pubspec.yaml:14:15

   ╷
14 │   mongo_dart: ^0.3.2
   │               ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
60
pub points
10%
popularity

MongoDB serializer helpers for jaguar_serializer

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

tejainece@gmail.com

License

BSD (LICENSE)

Dependencies

jaguar_serializer, mongo_dart

More

Packages that depend on jaguar_serializer_mongo