jaguar_query_sqflite 2.2.11
jaguar_query_sqflite: ^2.2.11 copied to clipboard

Flutter Android iOS macOS

SQFLite database adapter for jaguar_query for Flutter. Use it in combination with jaguar_orm to write concise and readable database queries.

5
likes
80 / 110
pub points
82 %
popularity

We analyzed this package on Feb 27, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 17 out of 51 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:jaguar_query_sqflite/jaguar_query_sqflite.dart that imports:
  • package:jaguar_query_sqflite/src/adapter.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/adapter.dart:21:18

   ╷
21 │   SqfliteAdapter.FromConnection(sqf.Database connection)
   │                  ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/adapter.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
jaguar_query^2.2.92.2.92.2.9
sqflite^1.1.7+21.3.2+32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
meta-1.3.0-nullsafety.31.3.0
path-1.7.01.8.0
sky_engine-0.0.990.0.99
sqflite_common-1.0.3+12.0.0
synchronized-2.2.0+23.0.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.7+2` on sqflite does not support the latest published version `2.0.0`

pubspec.yaml:19:12

   ╷
19 │   sqflite: ^1.1.7+2
   │            ^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Flutter 1.22.6, Dart 2.10.5.

5
likes
80
pub points
82%
popularity

SQFLite database adapter for jaguar_query for Flutter. Use it in combination with jaguar_orm to write concise and readable database queries.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

tejainece@gmail.com
jimmy.aumard@gmail.com

License

BSD (LICENSE)

Dependencies

flutter, jaguar_query, sqflite

More

Packages that depend on jaguar_query_sqflite