jaguar_postgres 2.4.1

Dart native
Flutter Android iOS

A postgres interceptor for Jaguar

0
likes
70 / 110
pub points
37 %
popularity

We analyzed this package on Sep 29, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 7 API elements (28.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:jaguar_postgres/jaguar_postgres.dart that imports:
  • package:jaguar_postgres/src/interceptor.dart that imports:
  • package:jaguar_postgres/src/manager.dart that imports:
  • package:postgres/postgres.dart that imports:
  • package:postgres/src/execution_context.dart that imports:
  • package:postgres/src/connection.dart that imports:
  • package:postgres/src/client_messages.dart that imports:
  • package:postgres/src/query.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

INFO: Use `=` to separate a named parameter from its default value.

lib/src/interceptor.dart:16:19

   ╷
16 │       {String host: 'localhost',
   │                   ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/interceptor.dart

INFO: Use `=` to separate a named parameter from its default value.

lib/src/interceptor.dart:17:15

   ╷
17 │       int port: 5432,
   │               ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/interceptor.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
conn_pool^2.1.82.1.92.1.9
jaguar^2.4.42.4.442.4.44
postgres^1.0.01.0.22.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
auth_header-2.1.42.1.4
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
http_server-0.9.8+30.9.8+3
jaguar_common-2.1.42.1.4
jaguar_serializer-2.2.122.2.12
logging-0.11.40.11.4
meta-1.2.31.2.3
mime-0.9.70.9.7
path-1.7.01.7.0
path_tree-2.2.42.2.4
stack_trace-1.9.51.9.5
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on postgres does not support the latest published version `2.2.0`

pubspec.yaml:14:13

   ╷
14 │   postgres: ^1.0.0
   │             ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs