jaguar_orm_gen 2.2.30
jaguar_orm_gen: ^2.2.30 copied to clipboard

Generator for jaguar_orm

0
likes
50/ 130
pub points
48%
popularity

We analyzed this package on Oct 15, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2021-10-15T05:47:56.670797] Starting...
Documenting jaguar_orm_gen...
Initialized dartdoc with 886 libraries in 85.0 seconds
Generating docs for library jaguar_orm_gen from package:jaguar_orm_gen/builder.dart...
Generating docs for library jaguar_orm_gen from package:jaguar_orm_gen/jaguar_orm_cli.dart...
Documented 2 public libraries in 0.7 seconds

stderr:   warning: jaguar_orm_gen has no library level documentation comments
    from jaguar_orm_gen: (file:///tmp/pub-dartlang-dartdocMAUMGM/pkg/lib/builder.dart:1:9)
  error: failed to write file at: jaguar_orm_gen/jaguar_orm_gen-library.html
    for symbol jaguar_orm_gen: (file:///tmp/pub-dartlang-dartdocMAUMGM/pkg/lib/jaguar_orm_cli.dart:7:9)
    conflicting with file already generated by jaguar_orm_gen: (file:///tmp/pub-dartlang-dartdocMAUMGM/pkg/lib/builder.dart:1:9)
            Dartdoc generates a path and filename to write to for each symbol.
            jaguar_orm_gen conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
  warning: unresolved doc reference [GenSerializer]
    from jaguar_orm_gen.BeanGenerator.generateForAnnotatedElement: (file:///tmp/pub-dartlang-dartdocMAUMGM/pkg/lib/src/hook/hook.dart:25:18)
  warning: unresolved doc reference [Api]
    from jaguar_orm_gen.BeanGenerator.generateForAnnotatedElement: (file:///tmp/pub-dartlang-dartdocMAUMGM/pkg/lib/src/hook/hook.dart:25:18)
  warning: unresolved doc reference [api]
    from jaguar_orm_gen.BeanGenerator.generateForAnnotatedElement: (file:///tmp/pub-dartlang-dartdocMAUMGM/pkg/lib/src/hook/hook.dart:25:18)
Found 4 warnings and 1 error.
Unhandled exception:
encountered 1 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:241:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:33:19)
<asynchronous suspension>


Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:jaguar_orm_gen/builder.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/writer/writer.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.38.00.38.52.6.0
build^1.2.21.6.22.1.1
jaguar_orm^2.2.72.2.72.2.7
jaguar_query^2.2.92.2.92.2.9
logging^0.11.3+20.11.41.0.2
meta^1.1.81.7.01.7.0
source_gen^0.9.4+60.9.4+61.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.3.0
async-2.8.22.8.2
charcode-1.3.11.3.1
clock-1.1.01.1.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.16.20.17.1
dart_style-1.3.32.2.0
file-5.2.16.1.2
front_end-0.1.270.1.29
glob-1.2.02.0.2
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
kernel-0.3.270.3.29
matcher-0.12.110.12.11
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.0
quiver-2.1.53.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.38.0` on analyzer does not support the stable version `0.39.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.2.2` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.