jaguar_mongo_data_store 2.2.0
jaguar_mongo_data_store: ^2.2.0 copied to clipboard

Data store (CRUD abstraction) implementation for MongoDb

0
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Dec 1, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 31 API elements (19.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:jaguar_mongo_data_store/jaguar_mongo_data_store.dart that imports:
  • package:jaguar_mongo_data_store/src/mongo_data_store.dart that imports:
  • package:mongo_dart/mongo_dart.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
jaguar^2.2.42.4.463.0.12
jaguar_data_store^2.2.02.2.02.2.0
jaguar_mongo^2.2.02.4.12.4.1
jaguar_serializer^2.2.02.2.122.2.12
mongo_dart^0.3.30.3.60.7.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
auth_header-2.1.43.0.1
bson-0.3.41.0.4
characters-1.2.01.2.0
charcode-1.3.11.3.1
client_cookie-2.1.53.0.2
collection-1.15.01.15.0
conn_pool-2.1.92.1.9
convert-2.1.13.0.1
crypto-2.1.53.0.1
fixnum-0.10.111.0.0
http_parser-3.1.44.0.0
http_server-0.9.8+31.0.0
jaguar_client-2.4.22.4.2
jaguar_common-2.1.43.0.0
jaguar_resty-2.8.93.0.0
logging-0.11.41.0.2
meta-1.7.01.7.0
mime-0.9.71.0.1
mongo_dart_query-0.3.21.0.2
more-2.8.03.3.0
path-1.8.01.8.0
path_tree-2.2.43.0.0
pool-1.5.01.5.0
rational-0.3.82.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.2.4` on jaguar does not support the stable version `3.0.5`.

Try running dart pub upgrade --major-versions jaguar to update the constraint.

The constraint `^0.3.3` on mongo_dart does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions mongo_dart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
70
pub points
0%
popularity

Data store (CRUD abstraction) implementation for MongoDb

Homepage (insecure)

Documentation

API reference

License

unknown (LICENSE)

Dependencies

jaguar, jaguar_data_store, jaguar_mongo, jaguar_serializer, mongo_dart

More

Packages that depend on jaguar_mongo_data_store