jaguar_hotreload 2.0.2
jaguar_hotreload: ^2.0.2 copied to clipboard

Hot reloader for Dart. Reloads your application whenever a file system change is detected in the source files or registered files.

2
likes
90 / 110
pub points
52 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/jaguar_hotreload_example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 30 out of 31 API elements (96.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:jaguar_hotreload/jaguar_hotreload.dart that imports:
  • package:jaguar_hotreload/src/jaguar_hotreload_base.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
glob^1.1.31.2.02.0.1
vm_service_lib^0.3.50.3.10+23.22.2+1
watcher^0.9.70.9.7+151.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
file-5.2.16.1.0
intl-0.17.00.17.0
js-0.6.30.6.3
meta-1.3.01.3.0
node_interop-1.2.12.0.0
node_io-1.2.01.2.0
path-1.8.01.8.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.1.3` on glob does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions glob to update the constraint.

The constraint `^0.3.5` on vm_service_lib does not support the stable version `3.14.1`.

Try running dart pub upgrade --major-versions vm_service_lib to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

2
likes
90
pub points
52%
popularity

Hot reloader for Dart. Reloads your application whenever a file system change is detected in the source files or registered files.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

tejainece@gmail.com

License

BSD (LICENSE)

Dependencies

glob, vm_service_lib, watcher

More

Packages that depend on jaguar_hotreload